19 件のコメントがあります。

スパムブロック機能により、投稿が失敗することがあります。
うまくいかない場合は、一行目だけをまず投稿し、そのあと編集から残りを追記してみてください。

1 - 19 / 19

» パーソナルWeb共有をhttps接続できるようにしよう

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : oba @ 2006-02-08 02:58:26 編集 引用

 現在Xserver 10.3上にosCommerceを立ち上げており、テスト状況下のSSL接続の構築に非常に役に立ちました。
 ありがとうございます。 素のOS Xをここまでサーバー化される知識と努力には頭が下がります。
 ただ一点、「server.keyとserver.crtの設置」の部分で「/System/Library/OpenSSL/certに移動」とありますが、これは「certs」の間違いですね?(貼付けられている画面キャプチャーから判断)
 GUIではcertに移動しようとしても無理ですが、ターミナルからmvすると一見可能のように見え、ファイルが消えてしまいます。

※揚げ足を取るつもりはありません。
 これからもよろしくお願いします。

おお。

From : namahage @ 2006-02-08 14:03:11 編集 引用

obaさんこんにちは。
誤植を教えていただいてどうもありがとうございます。
いやー、これは/certsのまちがいですね。
さっそく直したいとおもいます。たすかりました。

普段から私はよく「おまえは料理とタイピングは雑だから気をつけて...。」
とよくいわれるんですよ。

これで引っかかっていた人がいたらわるかったなぁなんてちょっと思ってしまいました。
またどこかに間違いがあるといけませんので、そんな場所にであったときにはぜひ教えてください。

osCommerce環境の構築にお役に立てて何よりです。
おもしろい情報なんかもお待ちしております。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-07-23 10:26:59 編集 引用

初心者です。Mac OSX 10.4.7でosCommerceのインストールまでたどり着きました。 「パーソナルWeb共有をhttps接続できるようにしよう」で悪戦苦闘しています。「https://127.0.0.1/」での接続は何となく成功しました(証明書を表示で「有効ではありません、ホスト名が一致しません。」 とでます)。が、ドメイン名での接続がうまくゆきません。(BINDはちゃんと起動しているとおもいますが。)どうか、よいアドバイスを頂けたらと思います。よろしくお願いします。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-07-23 19:58:31 編集 引用

Rout 53さん、こんにちは。
SSLの設定はステップが多くて、何度やっても不安が残る作業でいつも私はどきどき過ごしています。

さて、「https://127.0.0.1/」での接続はうまくいって、「https://www.mydomain.com/」のようなドメイン名からの接続はうまく行かないとのことですね。

これは、ページを読み込みにいったまま表示されないということでしょうか?
それから、「https://www.mydomain.com/」への接続はサーバーのMac自身からの接続ですか?それともLAN内であったりインターネット上からであったりしますか?

ページを読みにいったまま表示がいつまでもされないということでしたら、一度、アプリケーションフォルダ>ユーティリティの中にあるコンソールを起動して、/var/httpd/access.logとerror.logあとssl_engine_logあたりをみてみると何かわかることがあるかもしれません。

それからもし、インターネット上からの接続テストだとしますと、httpsの接続にはポート番号443が開いている必要があります。ルータを設置していたり、Firewallが起動していたりする場合は、443をあけるように設定をする必要がでてきます。

今思いついたところではこのぐらいでしかなくてすいません。
ちょっと試してみてください。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-07-24 09:46:41 編集 引用

namahage さん
さっそくのお返事、丁寧なアドバイスありがとうございます。
ここ1~2日かけてがんばってみたいと思います。経過および結果を報告させていただきますのでまたよろしくお願いいたします。
それにしても、私のような者にもわかるような丁寧な解説に頭がさがります。
ほんの少しかもしれませんが、コンピュータのことに理解が深まり勉強になっております。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-07-26 14:15:48 編集 引用

namahage さん
経過報告します。
<ルータを設置していたり、Firewallが起動していたりする場合は、443をあけるように設定をする必要がでてきます。>
はルーターの設定をいたしました。しかし 以下のようになりました。
「https://127.0.0.1/」での接続では前回同様つながりますがerror logで
「[error] [client 127.0.0.1] File does not exist: /Library/WebServer/Documents/favicon.ico」となりました。
LAN内からの「ドメイン名からの接続」では「セキュリティ保護された接続を確立できませんでした。」となり、
access log   222.x.xxx.94 - - [26/Jul/2006:14:09:24 +0900] "\x80L\x01\x03\x01" 501 -

error log [error] [client 222.x.xxx.x4] Invalid method in request \\x80L\\x01\\x03\\x01 となります。
なにかヒント、アドバイスをお願いいたします。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-07-26 21:10:02 編集 引用

こんにちは。
まずはこのエラーですね。

[error] [client 127.0.0.1] File does not exist: /Library/WebServer/Documents/favicon.ico

これは、favicon.icoというアイコンファイルをブラウザが探しているけれども、見つからないというエラーです。わたしのサイトの場合、URLのところに「羽にハート」のアイコンが表示されていると思います。favicon.icoはこの画像を表示させるアイコンのファイルです。最近のブラウザはほとんどがこのアイコンファイルを探すようになっています。とりあえず、今回のSSLのことでは心配しなくても良さそうです。

で、問題はこのエラーかとおもいます。

[error] [client 222.x.xxx.x4] Invalid method in request \\x80L\\x01\\x03\\x01

これ、わたしもなんとなく見覚えがあります。
だいぶはまり込んで、乗り越えるのに苦労した記憶があります。
そして、どうやって乗り越えたのか、うっかりもののわたしはなんだか思い出せません。

たしかhttpd.confに追記した文章の一部が、バックスラッシュと記述されているか¥と記述されているかで起きる問題だったような気がします。これは文字コードの問題で起きるそうです。

ちょっとチェックしてもらいたいことがあります。
httpd.confに記述した部分の下から17行目ぐらいにある

<Files ~ "\.(cgi|shtml|php)$">

ここの <Files ~ " の後ろ、
¥になってますか?
\になってますか?
(表記の都合全角で書いてますけども半角です)

もし¥になっているとしたら、うまくいかないような気がします。
ここが¥になっているとすると、ほかにも\が¥になっていることになりますので、その場所についてもなおさないとけなくなりそうです。6カ所ぐらいありますか。

これでダメなときには、
下から4行目3行目にある記述、

CustomLog /var/log/httpd/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

これを

#CustomLog /var/log/httpd/ssl_request_log \
#"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

にしてみてください。
なんとなくここもいじってみたような記憶があります。

それではがんばってみてください。

あと参考までにAppleさんのSSL設定に関するページはここにあります。
SSLと英語の勉強に目がかすみそうになります。
http://developer.apple.com/internet/serverside/modssl.html

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout53 @ 2006-07-30 11:26:45 編集 引用

namahageさん
迷宮いりの気分です。
バックスラッシュの件について経過を報告します。
httpd.confに追記した文章について、記述した部分の下から17行目ぐらいにある
<Files ~ "\.(cgi|shtml|php)$">jについては\(バックスラッシュ)にかえても問題ないのですが、それ以下の5カ所について変更するとターミナルのチェックで以下のようにでます。

chikaxxxxr:~ chikaxxxxr$ apachectl configtest
Processing config directory: /private/etc/httpd/users/*.conf
Processing config file: /private/etc/httpd/users/+entropy-php.conf
Processing config file: /private/etc/httpd/users/chikaserver.conf
Syntax error on line 1179 of /etc/httpd/httpd.conf:
Invalid command 'nokeepalive', perhaps mis-spelled or defined by a module not included in the server configuration
となります。
また、思考錯誤のなかwebminnの「Apacheモジュール」で[mod_php5]と[mod_apachessl]がアクティブになってないのでこれにチェックをいれてApacheを起動すると[ Syntax error on line 282 of /etc/httpd/httpd.conf:
Cannot add module via name 'mod_apachessl.c': not in list of loaded modules
/usr/sbin/apachectl start: httpd could not be started ]となります。
よいアドバイスをお願いいたします。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-07-31 21:05:04 編集 引用

こんにちは。
いやーたいへんになってきましたね。

Syntax error on line 1179 of /etc/httpd/httpd.conf:
Invalid command 'nokeepalive', perhaps mis-spelled or defined by a module not included in the server configuration

ここのところは、httpd.confの1179行目に入力ミスがあって、これが原因でうまく読み込みできないといっているように思います。実際のところ入力ミスというかバックスラッシュとかの兼ね合いのような気もします。とりあえず確認してみたいのは、1179行目の前後にはなにがあるかでしょうか?"nokeepalive"ときていますので...

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0

これか、

CustomLog /var/log/httpd/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

これあたりがありそうな気がします。

SetEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0

この3行はSSL接続がうまく行かないInternet Explorer用の設定だそうです。
オフにすると実際の運営時にこんどは何かしら問題があるかもしれませんが、とりあえず、いま目の前の問題を切り分けるのに、この3行の頭に#をつけて、apacheに読み込ませないようにさせてからconfigtestを行ってみるのもよいかと思います。あわせて、

CustomLog /var/log/httpd/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

ここの頭にもそれぞれ#をつけてやってみるとどうなるでしょうか。
これでSyntax OKがでたらまた対応を考えてみましょう。

それから、webminのapache Moduleのことですが、これは手を付けない方がよいような気がします。実際のところわたしもよくわかっていませんけれども、Entropy PHPがhttpd.confにModuleを有効化するようにすでに書き込んでいるはずだとおもいますので、なにかしらでぶつかってしまうような気がします。なので、元に戻せるのであればチェックを外してみてから、上記の作業をためしてみてください。

それではがんばってください。

わたしもTiger, apache1.3.x, SSL, php5をいじれる環境を用意してちょっと試してみます。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout53 @ 2006-08-02 13:08:29 編集 引用

namahageさん こんにちは おいそがしいところ つきあわせて申し訳ありません。バックスラッシュの件ですが、(カナ入力+option+?)で入力してます。英数入力では(ヌの半角)になります。で打ち込んだ(\)をコピーしようとすると「選択文字列の中にUnicodeへ変換できない文字がありました。内部文字コードでコピーします。」とでます。これではまずいんでしょうか?
 それから、ご指摘の方法は(\=¥)のままやってみましたが [warn] module mod_php5.c is already added, skippingとでるもののSyntax OKとなりいつものようにlocalでつながりLANでだめという結果でした。
また、東京ゴムボートさんのpageでは「apache2の導入で解決」とされていますが、この方法には一考の価値はあるでしょうか?
よきヒントを混乱男にお授けください。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-08-02 16:25:25 編集 引用

訂正です///
誤 (カナ入力+option+?)で入力
正 (カナ入力+option+¥)で入力
すみません!tohoho...

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-08-03 21:30:22 編集 引用

どうもこんにちは。
いやー、なかなか煮詰まってきましたね。
私レベルで乗り切れるものか不安ですが、がんばりたいところであります。

とりあえず、このエラーのことです。

[warn] module mod_php5.c is already added, skipping

これは気にしなくてもよいと思います。EntropyPHPをインストールすると必ず出るものみたいで、このままでも特に問題は起きないようです。

で、以下の5行を#でふさいで、configtestをした結果、Syntax OKとでているようですので、

tEnvIf User-Agent ".*MSIE.*" \
nokeepalive ssl-unclean-shutdown \
downgrade-1.0 force-response-1.0

か、
CustomLog /var/log/httpd/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

あたりにApacheがうまく起動できない、SSL moduleが読み込まれない理由がありそうな気がします。

バックスラッシュをうまく入力できない件ですが、
http://earlybirds.ddo.jp/namahage/inegalog/resources/https/httpdconf_ssl.html

このページを開くと<IfModule mod_ssl.c>の内容が表示されると思います。
この内容をすべて選択し、丸ごとドラッグアンドドロップでデスクトップに「クリッピングテキスト」として取り出してみてください。(わかりますか?)

このクリッピングテキストファイルをそのままドラッグアンドドロップで、httpd.confの貼付けたい場所に放り込めば文字化けなくコピー&ペーストできると思います。

この手順で、<IfModule mod_ssl.c>の内容を貼付けた後、

CustomLog /var/log/httpd/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"

だけ#でふさいで、また挑戦してみたらどうなるでしょうか。
一つ試してみてください。

Apache2とバーチャルドメインについてはわたしもよくわからないんですけども、Rout53さんのおつかいの環境によってはそうしたケースもあるのかもしれませんです。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-08-04 15:28:12 編集 引用

namahageさん お世話になります。
バックスラッシュの件ですが、うまくできました。
   <CustomLog /var/log/httpd/ssl_request_log \
    "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
    だけ#でふさいで、また挑戦してみたらどうなるでしょうか。>
を実行しましたが成果ありませんでした。
現状を整理すると「https://127.0.01/」ではつながりますが、
「https://ドメイン名.net/」では当機からもLAN内からもつながりません。
しばらくがんばってみようとおもいますが、また何かよいヒントがありましたら
よろしくお願いいたします。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-08-10 20:29:50 編集 引用

どうも、混沌としてきました。
いや、実はですね、テストに用意したMacでも同じ症状が出ています。
これはPather機なんですけれども、ログファイルが混沌としてきました。

なにか解決のヒントが見つからないか
ちょっともうすこし手をかけてみたいとおもいます。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2006-08-11 08:26:48 編集 引用

夢でウンウン考えながら抜け道にたどり着きました。
そもそも私のページの記述にもまずいところがありました。
私のページにあるhttpd.confへの記述には、
(中略)
<VirtualHost 127.0.0.1:80>

(中略)
<VirtualHost 127.0.0.1:443>

と記述している部分があります。
ココは本来は、お使いのサーバーネームにあわせて、

<VirtualHost mydomain.ddo.jp:80>

などのように記述するのが正しいと思うのですが、
ページでは127.0.0.1となっていました。
一度ココをおつかいのドメインネームに変更してみてください。

で、
これでうまく行けばいいのですが、
私の場合、うまく行かない環境のPanther機では、ここをドメインネームに切り替えましたが、やはりうまく行きませんでした。127.0.0.1ではSSL接続できても、192.168.0.5やmydomain.ddo.jpではRout 53さん同様アクセスできないという具合です。

八方ふさがりで、Apache2系に逃げようかと思ったりしたのですが、
webを徘徊たどり着いたこちらの記述にヒントを得ました。

法大奥山研究所さん
http://okuyama.mt.tama.hosei.ac.jp/unix/macosx/apple_modssl.html

のページに記述されているhttpd.confをみますと、

<VirtualHost mydomain.ddo.jp:80>

などの部分を、

<VirtualHost *:80>

のようにワイルドカードとして設定していました。
この設定が使えるとなりますと、127.0.0.1であっても、192.168.0.5であってもmydomain.ddo.jpであっても同じものとして扱えることになります。

私の不具合環境(?)ではこの設定でうまくSSLによる接続が何処からでもできるようになりました。

SSLの仕組みについてあまり詳しくないので、より強固なSSLという見方からするとこれが十分なものなのかはよくわからないのですが、とりあえずの対策としてはうまく行くと思います。

それではがんばってみてください。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : Rout 53 @ 2006-08-12 11:41:14 編集 引用

manahageさん
ありがとうございました。できました!
<VirtualHost 127.0.0.1:80>の部分を、<VirtualHost *:80>に
<VirtualHost 127.0.0.1:443>の部分を、<VirtualHost *:443に>に
かえてみましたところ、LAN内からついにつながりました。
何週間か続いた暗闇の迷路から陽のあたる場所に出てきた気分です。
ゆっくりお盆休みを迎えられます。
外からつながるかどうかこれから家にかえって試してみます。
本当にありがとうございました。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : tamisuke @ 2007-12-19 01:26:51 編集 引用

はじめまして 初心者です
ここ1週間ほどこのサイトで勉強させていただいております。
Rout53さんの記述にもありましたが
バックスラッシュの件ですが一度クリッピングテキストとしてデスクトップに取り出し、mi上の任意の場所にドラッグするのですが、やはり\が¥にかわって貼付けられてしまいます。
症状的にもhttps://127.0.0.1では 開けるものの
https://(自分のドメイン)ではRout 53さんと同じようなものでした。
(ちなみにデスクトップに取り出したクリッピングテキストでは\でmiにドラッグした時点で¥にかわります。
ネットでも入力の仕方等検索しましたが、そのまま認識しますもしくは、さらに難しい操作を強いられるようなものでしたので、知恵をおかりしたく投稿させていただきました。どうかよろしくお願いします
ちなみに OS10.4.11 PowerPC G3 600Mhz ことえりを使用しています。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : namahage @ 2007-12-19 09:30:41 編集 引用

tamisukeさん、どうもこんにちは。
辺境のささやかなサイトですけれども、お役に立れてば嬉しい限りです。

さて、バックスラッシュの入出力についてです。
これは私も頭の中が混乱しています。¥に変換されているのに気がつかず、うっかりと設定ファイルをおかしくしてしまったりすることがときどきあります。

経験的にわかってきましたのは、
miやテキストエディットでファイルを開くとき、そのソフトがファイルをちょっと勘違いした形式で開いてしまう場合があるということです。

ファイルには文字コードというのがいくつかあるわけですが、そのいろいろとある形式のウチ、UTF-8で開かれなければいけないものをShift-JISで開いてしまったりすると、本来表示される文字が変わってしまう、そんな具合です。

今回の場合ですと、
https用の設定を貼り付ける際、httpd.confをmiで開く操作があります。httpd.confはUTF-8という形式の文字コードでかかれていますので、このときUTF-8という形式でファイルが開かれないといけないわけですが、miはたぶんShift-JISという形式で開いていると思います。ウィンドウ上の方にある表示をちょっと確認してみてください。

たぶん、httpd.confの中をよく見ますと、他のところにかかれている\はすでに¥に変わってしまっているかもしれません。このまま作業してもファイル全体の整合性がとれていれば問題は起きませんが、ウッカリするとトラブルの元になってしまいます。

ちょっとややこしい話になってきましたので、とりあえずの対策を書きますと、miではなくCotEditorまたはJeditを利用してみてください。CotEdirotはAYNiMacさんのところからダウンロードできます。
http://www.aynimac.com/p_blog/files/article.php?id=41

CotEditorならそのまま開くだけで、UTF-8で表示してくれると思います。
うまくいかない場合は、メニューのファイルから「開く」を実行すると、ダイアログが出ます。よくみると下の方に「エンコーディング」とかかれているポップアップメニューがあります。ここをクリックしてUTF-8を指定してから、httpd.confを開いてみてください。Jeditでも同じです。

ここにhttps用の設定がかかれたクリッピングテキストを貼り付ければ、バックスラッシュも正しく入力された状態でファイルを設定できるはずです。

これでまだうまく接続できないと言うことでしたら、別のところに問題があるかもしれません。そのときはまた一緒に考えましょう。

それではがんばってみてください。

Re: パーソナルWeb共有をhttps接続できるようにしよう

From : tamisuke @ 2007-12-19 15:48:09 編集 引用

できました!!!
結局 \の件を教えていただいたエディタでさいど編集し(コピペ)して
そのままではやはりだめでしたのでRout 53さん同様に
<VirtualHost 127.0.0.1:80>の部分を、<VirtualHost *:80>に
<VirtualHost 127.0.0.1:443>の部分を、<VirtualHost *:443に>に
したところ無事 内部LANからも
外部からも接続かくにんできました。
ありがとうございます。

これからも このサイトを愛読させていただき、
勉強にはげみたいと思います。

どうもありがとうございました。

Post Your Comment


*は入力必須です。E-Mailは公開されません。