1 件のコメントがあります。

スパムブロック機能により、投稿が失敗することがあります。
うまくいかない場合は、一行目だけをまず投稿し、そのあと編集から残りを追記してみてください。

1 - 1 / 1

Lion ServerでVPNに接続できない問題のこと

From : namahage @ 2015-07-07 17:39:02 編集 引用

手持ちのLion Serverのうち、実装されているVPNサーバーを起動しても、クライアントからどうにもこうにも接続できないものが一台ありました。
クライアント側から接続しようとすると、system.logには次のようなログが出力されます。

racoon: Connecting.
racoon: IPSec Phase1 started (Initiated by peer).
racoon: IKE Packet: receive success. (Responder, Main-Mode message 1).
racoon: IKE Packet: transmit success. (Responder, Main-Mode message 2).
racoon: IKE Packet: receive success. (Responder, Main-Mode message 3).
racoon: IKE Packet: transmit success. (Responder, Main-Mode message 4).
racoon: IKEv1 Phase1 AUTH: success. (Responder, Main-Mode Message 5).
racoon: IKE Packet: receive success. (Responder, Main-Mode message 5).
racoon: IKEv1 Phase1 Responder: success. (Responder, Main-Mode).
racoon: IKE Packet: transmit success. (Responder, Main-Mode message 6).
racoon: IKE Packet: transmit success. (Information message).
racoon: IKEv1 Information-Notice: transmit success. (ISAKMP-SA).
racoon: IPSec Phase1 established (Initiated by peer).
racoon: IPSec Phase2 started (Initiated by peer).
racoon: IKE Packet: receive success. (Responder, Quick-Mode message 1).
racoon: IKE Packet: transmit success. (Responder, Quick-Mode message 2).
racoon: IKE Packet: receive success. (Responder, Quick-Mode message 3).
racoon: IKEv1 Phase2 Responder: success. (Responder, Quick-Mode).
racoon: IPSec Phase2 established (Initiated by peer).

一件上手くいきそうにみえるのですが、このあとIPアドレスの取得の段階で

vpnd: --> Client with address = 192.168.x.x has hungup

こんな感じのログが続き、hungupで接続がこけます。
同様のエラーで、海外のDiscussion board でも苦労されている例があり、私もその例に漏れずに、いろいろな回復作業を調べたり、試したりしてみましたが、いっこうに直すことができず、お手上げ状態でしたが、今日、ふとみた、VPNサービス設定画面の????
な記述から、無事、出口にたどり着くことが出来ました。同じようなトラブルに遭っている人のため、なにより自分の備忘録のために、メモを残しておきたいと思います。

ふと、Server.appのVPNサービス設定画面にある「クライアントDNS情報」に目をやると、「ネームサーバー1個、ドメイン0個」と設定されていることに気がつきました。あれ?ネームサーバー設定した覚えないんだけどな。そう思って、「編集...」ボタンをクリックし、先に進むと、たしかに「接続したクライアントにこれらのネームサーバーを提供:」リスト上は「真っ白」で、一つも設定されてないようです。

この表示上の「1個」と、リストの「真っ白」、この表示の矛盾はどうなっているのだろうと、考えてみました。

そして気がつきました。
「接続したクライアントにこれらのネームサーバーを提供:」リストの下に、「接続したクライアントにこれら検索ドメインを提供:」リストありますが、良く見ると、そちらは、グレーの文字で「検索ドメインを追加するには"+"をクリックします」と書かれています。何も設定していないと、ここの欄にはこういった文字が出るようです。

では一方、「接続したクライアントにこれらのネームサーバーを提供:」リストは、どうなっているかというと、グレーの文字があるのではなく「真っ白」なのです。「はっ!」と気がついて、「接続したクライアントにこれらのネームサーバーを提供:」リストの一番上の行をクリックすると、不思議なことに、なにかが選択されるのです。

まさかと思い、その空白の一行を左したの「−」ボタンで削除したところ、グレーの文字で「ネームサーバーを追加するには"+"をクリックします」というグレーの文字が現れました。どうやらなにか不明のデータが設定されてしまっていたようです。

ネームサーバーリストに改めて何も入力されていないことを確認後、OKを押し、VPN再起動を押し、再起動させました。
その後、iOSからVPN接続を試したところ、すんなりと接続できるようになりました。

まさか、こんなところが...という印象の不具合でした。
なにかと評判の良くなかったLion ServerのVPNサービスですが、同様のエラーに合われている方(今さらいないとは思いますが)、確認をしてみると良いかと思います。

Post Your Comment


*は入力必須です。E-Mailは公開されません。