6 件のコメントがあります。

スパムブロック機能により、投稿が失敗することがあります。
うまくいかない場合は、一行目だけをまず投稿し、そのあと編集から残りを追記してみてください。

1 - 6 / 6

httpsにつながらなくなった

From : アルミブック @ 2009-01-13 16:44:05 編集 引用

先日、アルミMacBookを購入し、それまで使っていた白MacBook(Late 2006)から移行アシスタントにて
環境をお引越ししました。白MacBook購入時は、FireWireで古いMacからお引越しを行い問題は起きてませんでした。
今回のお引越しで、httpsへの接続が出来なくなってしまいまして、もしかしたらこのサイトで何かしら対策情報を
お持ちでないか書込みさせて頂きました。
Safariでも、Firefoxでも同様なのでブラウザの問題ではなさそうなんです。
ちなみにエミュレータ VirtualBoxでXP起動した上でのfirefoxからもhttpsが通らない(タイムアウトになる)んです。
お引越しまえのHDDでの起動では、httpsに接続できます。
dolipoなどのプロキシは使わない環境です。どうなっているんでしょうか?

Re: httpsにつながらなくなった

From : namahage @ 2009-01-14 07:55:02 編集 引用

どうもこんにちは。

Safariがhttpsで始まるアドレスにアクセスできないという症状は、Mac OS Xのアップデートの歴史の中で、何度かあったように思います。具体的なことはほとんど覚えていないのですが、いくつかはアルミブックさんが書かれているようにproxyにかかわるものだったように思います。

アルミブック産の場合、proxy、ブラウザ種、エミュレータ上からのアクセスなどに関わりなく影響を受けているところを見るとMac OS X自体の問題のような気がします。

Apple USのディスカッションボードを見たところ、全く同じような症状にあわれている方を発見しました。

Topic : https pages blocked
http://discussions.apple.com/thread.jspa?messageID=8735796&#8735796

はっきりとした解決方法はまだ出ていないようです。

ブラウザを問わないところを見ると、接続先に送った接続要求が送れていないのか、向こうから届くサーバー証明書とキーを受信できていないのかということなのかもしれません。OS自体がなにかをブロックしているのでしょうか。

私のサイトのURLをhttpsに変えて一度アクセスしてみてください。
同じ症状になりますか?それとも認証を求めるダイアログぐらいは出ますか?

Re: httpsにつながらなくなった

From : アルミブック @ 2009-01-19 22:00:56 編集 引用

こちらのサイトを https でアクセスしても同じ症状でした。

Apple USのディスカッションボードを読みましたが、私の場合とほぼ同じの方が
沢山いるので驚きです。
ということでまだ未解決であります。

Re: httpsにつながらなくなった

From : namahage @ 2009-01-23 22:42:47 編集 引用

Mac OS X10.5.6で、SafariやFirefoxなどブラウザを問わず、httpsに接続できなくなる問題について、あちこち探してみました。

解決策はあまり多くないようです。

結局、US Appleディスカッションボードの更新を待っていたところ、ここ数日の書き込みで解決例がありました。この例によると、原因はペアレンタルコントロールだった、とあります。

ペアレンタルコントロールをoffにしたところ無事元通りhttpsサイトにアクセスできるようになったとあります。

アルミブックさんはペアレンタルコントロールを利用していますか?

Re: httpsにつながらなくなった

From : namahage @ 2009-01-25 18:07:59 編集 引用

実際に私の環境でもテストをしてみました。

デモ用に使用しているMacBook(Mac OS X10.5.6)です。
このMacBookにはアカウントが4つ存在していますが、その一つにペアレンタルコントロールを有効にしてみました。

まずシステム環境設定を起動し、ペアレンタルコントロールを開きました。
有効にしたいアカウントを選択し、Webサイト制限からSafariの制限を開きました。
ここにある「アダルトサイトへのアクセスを自動的に制限」にチェックをつけました。
このあとhttpsで始まるサイトにアクセスを試みたところ、アクセスすることができなくなっていました。
そこで、もう一度ペアレンタルコントロールに戻り、「アダルトサイトへのアクセスを自動的に制限」のチェックを外したところ、元通りhttpsで始まるサイトにアクセスすることができました。

面白いほど再現性があります。
原因はほぼここと思って間違いないように思います。

なんにしてもhttpsで始まるサイトが「アダルトサイトへのアクセスを自動的に制限」でフィルタされてしまうのはいかがなものかと思います。Appleさんには早い対応を期待したいところです。

Re: httpsにつながらなくなった

From : アルミブック @ 2009-01-27 00:44:09 編集 引用

アルミMacBookでそろそろ1ヶ月になるのに、解決法が無くTimeMachineを使った復元での
再インストールを計画してとりあえずバックアップをとりました。
私の場合、一度もペアレンタルコントロールを使ったことがなく、設定欄は空欄のままだったので
環境設定ではスルーしてました。何かの条件で設定欄が空欄でもペアレンタルコントロールが
有効で動作していたということでしょうか?
で、TImeMachineでのバックアップを取ったところで、試しにhttpsのサイトにアクセスしてみたら
なんと何事もなかったかのようにアクセスできるようになっていました。これもまた不思議であります。
とりあえず、httpsが通る様になったので報告いたします。
ペアレンタルコントロールについては私もやってみましたが、ご指摘のように再現性がありました。
ありがとうございました。

Post Your Comment


*は入力必須です。E-Mailは公開されません。