4 件のコメントがあります。

スパムブロック機能により、投稿が失敗することがあります。
うまくいかない場合は、一行目だけをまず投稿し、そのあと編集から残りを追記してみてください。

1 - 4 / 4

Joomla!を Win環境で見るとエラーが起きます。

From : KEIJI @ 2008-07-06 00:32:01 編集 引用

はじめましてKEIJIと申します。この間、MacOSX10.4.10にJoomla!を入れました。表示結果をブラウザで確認したところMacOSではエラーなく見られましたが、Winではエラー(文字は多少読み込みされますが、その後、エラー表示になります)が出て見られません。しかもそれがすべてのWinで見られないのではなく、ところどころで見られません。ちなみにそれらは同一のネットワーク内にあるものです。何分素人ですのでご教授ください。よろしくお願いします。

Re: Joomla!を Win環境で見るとエラーが起きます。

From : namahage @ 2008-07-07 20:16:25 編集 引用

KEIJIさん、どうもこんにちは。

Joomla!の表示がうまくいかないという原因ですが、Macでは問題なく見えて、Windowsではうまくいかないということですと、

1, Joomla!がおこなう処理(どちらかというとphpのほうかもしれません)に、Windowsのブラウザをうまく処理できていないところがあるかもしれない

2,URLの処理がちょっとうまくいっていないところがあるかもしれない。

3,Windowsのブラウザのキャッシュやcookieなどが引っかかっているかもしれない。

あたりを予想してみました。

1番の可能性はあまり考えられないと思います。

1番2番の可能性がある場合は、一度、ユーティリティフォルダからコンソールを起動して、ログの中から/var/log/httpd/access.logやerror.logをひらいてみると何か書いてあるかもしれません。MacでアクセスしたときとWindowsでアクセスしたときで、違いが何か記録されているかもしれません。

2番についてですが、Joomla!をインストールするとき、ステップ3でサーバーのURLを入力する欄があったと思います。LAN内の構成にもよりますが、ここの入力がmydomain.comのようなものだったか、IPアドレスだったかによって表示が影響されることがあると思います。ここには何を入力したか覚えていますか?

3番についてですが、これが一番可能性があるかもしれません。
ブラウザはInternetExplorerをお使いですか?
もし可能なら、InternetExplorer以外のブラウザでは正しく表示されるかどうかを試してみるとよいと思います。FireFoxやSafari for windowsで正しく表示されれば、問題の絞り込みができそうな気がします。

ほかのブラウザでうまく表示されることがわかったら、InternetExplorerのトラブルの可能性が出てきます。この場合は、キャッシュファイルを一度削除してみるとよいと思います。InternetExplorerなら、メニューのツールから、インターネットオプションを表示させ、インターネット一時ファイルの「ファイル削除」をおこなってみるとよいと思います。これでだめならCookieの削除も試してみるとよいかもしれません。

とりあえず、一度3番を疑ってみて、ほかのブラウザではどうなるかを試してみるということでどうでしょう。

それではがんばってみてください。

Re: Joomla!を Win環境で見るとエラーが起きます。

From : KEIJI @ 2008-07-08 13:07:08 編集 引用

お忙しいところ、早速のご回答いただきましてありがとうございます。

すみません。いくつか質問させてください。

1番についてですが、error.logで下記のエラーがありました。
[Tue Jul 8 12:55:41 2008] [error] PHP Notice: Undefined variable: user6 in /Library/WebServer/Documents/seisakublog/templates/simplify_green/index.php on line 94

2番についてですがステップ3とは
http://earlybirds.ddo.jp/namahage/inegalog/article.php?id=53
の「MySQLにJoomla!用のデータベースを作る」の項目でしょうか。

3番は一番最初にやっておりましたが、FirefoxでもSafariでもダメでした。

ちなみにですが、Win環境でも見られるものもありましたので双方(エラーあり、なし)の環境を比較して原因を探ってみたところ、AdobeCS3が入っているか、入っていないかの違いがありました。なのでエラーの出るWinにCS3インストールしてみたところなんと正常に見ることが出来ました。
これはいったいどういうことなのでしょうか。CS3と一緒に何か入ったのだろうと思いますが...。でもこれですと全PCにCS3を入れなくてはならないのでちょっとしんどい感じです。

すみませんが、よろしくお願いいたします。

Re: Joomla!を Win環境で見るとエラーが起きます。

From : namahage @ 2008-07-10 07:42:58 編集 引用

どうもこんにちは。
AdobeCS3をインストールすると状況が改善されるというのが、おどろきです。

Webサーバーから送られてくるデータをブラウザが処理、理解をして画面上に表示させているんだと思うのですが、問題のあるマシンではSafariでも、Firefoxでもだめというような、ブラウザに依存しないとなると、OS自身に近い場所になにか課題があることになってしまいますね。

一体何が起きているんでしょう。これは難しいです。
CS3をインストールすることによって、クライアントのWindows側になにか改善される環境が作成されているんでしょうか。

1番についてですが、error.logで下記のエラーがありました。
[Tue Jul 8 12:55:41 2008] [error] PHP Notice: Undefined variable: user6 in /Library/WebServer/Documents/seisakublog/templates/simplify_green/index.php on line 94

テンプレートにsimplify_greenを利用されているんですね。
既に試されていそうな気がしますが、このテンプレート以外を利用したらどうなりますか?

2番についてですがステップ3とは
http://earlybirds.ddo.jp/namahage/inegalog/article.php?id=53
の「MySQLにJoomla!用のデータベースを作る」の項目でしょうか。

わかりにくくてすみません。アンカーうっておこうかなとも思ったんですが横着してしまいました。ここは「Joomlaのインストール」のところです。「ステップ3のURLはあなたのサーバーのURLを入力します。ここはそれぞれお使いの環...」となっているあたりです。
ドメインネームやIPアドレスの解決がうまくできていないと、サーバー内部での処理とサーバーの外からの処理と、LAN側での処理がうまくいかないときがあるわけなんですが、今回のようにCS3を入れると解決するというのだと、ちょっとこのあたりはなさそうですね。

こちらでもどこかに環境を作って様子を見てみたいと思います。

Post Your Comment


*は入力必須です。E-Mailは公開されません。